PLEASE FOLLOW THIS HELPFUL GUIDE FOR SUCCESSFUL DEMO IMPORT.

- Our working time is from 9am until 5pm CET during weekdays.

- Tickets are ordered from oldest to latest, so please be patient, we will refer to your issue as soon as possible.

- When you submit a ticket, it would be really helpful if you could provide our agent with your website URL and wp-admin access in your private ticket. In that way, we will refer to your issue easier and faster.

Okay
  Public Ticket #1939611
Call to undefined function playerx_edge_create_wp_widget()
Closed

Comments

  • interas started the conversation

    Hello, I updated the theme "PlayerX" from version 1.2 to version 1.4 today (19.03.2019). After the update was finished, I get only one "HTTP ERROR 500". Here is the error message from the Errorlog of Apache2:

    PHP Fatal error:  Uncaught Error: Call to undefined function playerx_edge_create_wp_widget() in /var/www/HDS/Public/Wordpress/wp-content/themes/playerx/framework/modules/widgets/lib/widget-loader.php:9 Stack trace: #0 /var/www/HDS/Public/Wordpress/wp-includes/class-wp-hook.php(286): playerx_edge_register_widgets('') #1 /var/www/HDS/Public/Wordpress/wp-includes/class-wp-hook.php(310): WP_Hook->apply_filters(NULL, Array) #2 /var/www/HDS/Public/Wordpress/wp-includes/plugin.php(465): WP_Hook->do_action(Array) #3 /var/www/HDS/Public/Wordpress/wp-includes/widgets.php(1715): do_action('widgets_init') #4 /var/www/HDS/Public/Wordpress/wp-includes/class-wp-hook.php(286): wp_widgets_init('') #5 /var/www/HDS/Public/Wordpress/wp-includes/class-wp-hook.php(310): WP_Hook->apply_filters(NULL, Array) #6 /var/www/HDS/Public/Wordpress/wp-includes/plugin.php(465): WP_Hook->do_action(Array) #7 /var/www/HDS/Public/Wordpress/wp-settings.php(505): do_action('init') #8 /var/www/HDS/Public/Wordpress/wp-config.php(115): require_once('/var/www/HDS/Pu...' in /var/www/HDS/Public/Wordpress/wp-content/themes/playerx/framework/modules/widgets/lib/widget-loader.php on line 9

    Ive tried to reinstall the theme and wordpress. But nothing changed.

    Edit: The Site works after Update the PlayerX Core Plugin.

  •  1,962
    Edge replied

    Hello there,

    Sorry for late response, your ticket wasn't on the list due to problems with Ticksy.

    When it comes to error that you got affter theme update, it happened becuase you didn't deactivated and deleted Core plugin before updating.

    Please note that we changed some files in our Core plugin in the latest theme update, so it is very important to deactivate and delete the old version of Core plugin before upadating the theme. After successful updating, you can should login to wp-admin panel and go to plugins and install and activate Core 1.0.1.

    Anyhow, we checked your website and we could see that it is working properly now.

    If you have any question or you need our help, please never hesitate to contact us.

    Best Regards,

    Nemanja


    Customer Support

    Here you could check our work :) !